Adobe Dreamweaver - Basic Web Page Tutorial

Window Elements
While Dreamweaver can look very intimidating when it is first launched it is an easy program. Dreamweaver knows that your files must be organized and will help you save the files into a folder. In the Panels groups, (right side window) the panels can be expanded or collapsed by clicking the expander arrow to the left of the panel name. The panel showing your webpages is the Files panel.

If you do not see these same areas on your screen, go to the Window menu and select the appropriate ones. Window, Insert, Properties and Files should all have check marks beside them.

Defining Your Site
The very first thing to do is define a site to start creating a web site. These settings are necessary for publishing, will make it as easy as clicking one button. But you must realize that when you create web pages, you will be working with two sets of files - the local files (used for editing, works-in-progress) and the remote files (already published and available web pages). Student Tips: Even if you have already started a web page you must do this each time you sit down at a campus computer, otherwise Dreamweaver will not be able to publish your pages.
1. Select **Site, Manage Sites**.
2. A **Manage Sites** window appears, click on **New, Site**.

At the Site Definition window you will need to click on the **Advanced** tab to follow the tutorial. You will now need to Define Local and Remote details before starting to use the program.
Defining Your Local Site

Site Definition of Local Information: follow steps below.

1. On the Local Info page fill out the Site Name by putting in your web site name here. This will not show up on the web page, it is only used for reference on this program.

2. The Local Root Folder will be your folder for your publishing files. We suggest creating a folder on the network in your Private or Public folder. Click on the yellow folder to find the path to your folder. At Dickinson each student has their own folders which are found on the Y drive or it is called Resserv.

3. The HTTP Address will be the web address that will bring up your web page. An example of a web address for a personal website would be: http://users.dickinson.edu/~smith

4. Do not click the OK button.
Defining Your Remote Site

Site Definition of Remote Information: follow the steps for on campus, PC or Mac

1. Click on the Remote Info under the Category menu and a Remote Info window appears. Under Access choose Local/Network.

2. For PC computers, the Remote Folder will be W:/ for personal web pages. Click on the yellow folder; navigate to the Computer for the W drive. Click Open, then Select. For Mac computers click on Go, Connect to Server, type smb://users.dickinson.edu/websites$/~username and click Go. A SMB/CIFS System Authentication dialog box appears. Type in your Active Directory/Network/Gateway password and click OK. This will be the place to navigate to.

3. Your site has been defined, so just click OK. Click Done on the Manage Sites dialog box. You are now ready to go to the section called First Things First on page 6 and start publishing.
FTP site Details of Remote Info: for off campus - Mac or PC computers.

1. Follow the **Local Info** details on page 3.
2. **Access** is: FTP and **FTP Host** is: users.dickinson.edu
3. The **Host Directory** is: /~username  *Use the slash under the backspace key on the pc keyboard or delete key on a Mac.
4. **Login** is: username
5. **Password** is: Active Directory/Network/Gateway password, then click on the Test button.

You should get a **Successful Connection** dialog box. Click OK
First Things First

Before you even begin typing the content of a web page, get into the following habit:

From the File menu, select Save, after you have created a new page and before you start to edit it. Make sure to save the file in the folder you specified as the Local Root Folder when you initially defined the site.

In the Save As dialog box, enter a name for the file. If this page is your home page (see next section), make sure to name it index.htm or index.html. (Web pages can have either .htm or .html as their file extension.) Other pages can be named whatever you wanted following the rules below.

Rules for filenames:
- Avoid using long file names; keep them short
- Do not use spaces; you may use a hyphen or underscore to simulate separate words
- Use letters or numbers, but no special characters
- Stick to lowercase letters; files on the web server are case-sensitive

After the file has been saved, give the page a Title. At the top of the Document window, type in the Title box, then press Enter. Titles are displayed in a web browser's title bar only and will not actually appear as text within the page.

Creating a Home Page

A home page is a special web page - it's the page that automatically appears whenever someone browses to your web site. In order for the home page to automatically load, when it is created, it must be saved with a special name, index.htm or index.html. All other web pages you create can be saved with whatever name you like. Remember lowercase and no special characters!

Adding Text

Simply begin typing the text you want to add to the page. Press Enter only at the end of paragraphs, otherwise, let the text word wrap. Whenever you press Enter, a double-space will appear between the paragraphs of text. If you, instead, want only a single space, press Shift-Enter instead. This is called a line break, as opposed to a paragraph break.

You may add typical formatting, such as Bold or Italic by clicking the appropriate buttons on the Property Inspector. If you want to change text alignment (left, center, or right), just click the desired button on the Property Inspector.

Headings

There are six pre-defined heading sizes, 1 through 6, which are web page standards. Heading 1 is the largest and heading 6 is the smallest.
1. Make sure the cursor is on the line you want to change. On the Property Inspector, drop down the **Format** options and select the desired size.
2. Type the text for your heading and press **Enter**.
3. To return to normal text, drop down the **Format** options on the Property Inspector and select **Paragraph**.

**Indenting Text**

You can add indents as you're typing the paragraph or later. Just remember that indenting works on a paragraph by paragraph basis. If you want to indent the current paragraph, make sure the cursor is somewhere within the paragraph and click the **Text Indent** button on the Property Inspector. If you want to indent several paragraphs at the same time, simply select all the sequential paragraphs first, then issue the **Text Indent** command.

To remove an indent, make sure the cursor is within the paragraph, click the **Text Outdent** button on the Property Inspector.

**Selecting Text and Background Colors**

1. From the **Modify** menu, select **Page Properties**, select **Appearance** under **Category**. (see example below)
2. Select a **Text** color by clicking on the selection box to the right. A palette of web-safe colors appears. Just click on the color you want.

Select a **Background** color by clicking on the selection box to the right. A palette of web-safe colors appears. Just click on the color you want. Click **OK** to return to the document.
Inserting Graphics

Only two graphics formats are supported on the web are .GIF and .JPG.

1. The place the cursor where you want to insert the graphic. Click the Insert Image button on the Insert Bar.
2. Select the image file that you want to insert. (You save yourself time if you store your images in the same folder as your web page.) Notice at the bottom of the dialog box, that the images location in the URL field is Relative To the Document.
3. If you want to see a preview of the image before you select it, just place a check mark in the Preview Images check box. (Example above)
4. When your choices are complete, click Select to insert the image into the page. Notice the Property Inspector options have changed because you now have the image selected (See above example)
5. On the left side of the Property Inspector, there is a white box where you should enter a name for the image - do not use spaces. This is an internal name and, while not necessary, providing one is a good habit to begin.
6. On the right side of the Property Inspector, click in the Alt text box. Type another name for this graphic. The Alt tag is important to include because some individuals have visual impairments and their web browser will read it the contents of the Alt tag to them. You may use multiple words, spaces and capital letters in this box.
7. Finally, dropped down the Align option to select how text will align with the graphic. If you want text to wrap around the graphic, select either Left or Right. Only these two options can be used to wrap text around the graphic. All of the other selections only it work for single lines of text.
Adding Links to Other Web Pages

You can create links on your page to other web sites or to other pages you've created within your own web site. It's important to verify the accuracy of your links before you publish the page. Always preview your web page in your browser and test each individual link. More on that in the next section.

Anatomy of a Link

A link is either a piece of text or a graphic which, when clicked, will take your reader to another location on the web. This location could be another part of the page or a completely different page on your own web site, or it could be a page located on an entirely different web server. The link itself has two parts: 1) the clickable text or graphic and 2) the location on the web.

To create a link to someone else's web site:

1. Select the text for the link.
2. In the Property Inspector, click in the Link text box and type the URL for the web site, then press Enter. Always start the link with http:// otherwise the link will not work. (See example below using Google)

To create a link to another of your own web pages:

1. Select the text for the link.
2. In the Property Inspector, click the yellow folder icon at the end of the Link text box.
3. In the Select File dialog box, select the web page to which you want to link, then click Select.

Note: If the page you just selected hasn't previously been published, you must make sure to publish that page also in order for the link to work.
Adding an Email Link

If you want readers to be able to send you feedback or questions on your page, create an email link.
1. Position the cursor where you want the link to appear.

2. From the Insert Bar, click the Email Link button.
   (Or, if you'd rather use a menu, go to Insert and select Email Link.)

3. In the Text box (example above), enter the text you want to appear as the link on the page
4. In the E-Mail box, enter your full internet email address and Click OK.
   (smitht@dickinson.edu)

Linking to another location within the same page or named anchors

This is a trickier type of link because there are two processes you must perform. First you need to define the anchors, or the locations within the page where you want to jump to when someone selects the link. Once all of the anchors have been defined, then you create the links on the page to go to those anchors. Follow this process for each link:

1. To define an anchor, place the cursor at the beginning of the text you want to jump to.
2. On the Insert Bar, click the Named Anchor button.
3. On the Named Anchor dialog box (example above), type in the name you want for the anchor.
   It's a good practice to keep the anchor names relatively short, yet easy enough to remember, and do not use spaces and Click OK.
4. You will see a small yellow anchor appear to the left of the text
5. Repeat steps 1 through 4 until all anchors have been defined.
6. Now, define the link. Select the text you want for one of the links. In the Property Inspector,
   drag the Point to File icon (located to the right of the Link text box) to the associated anchor icon.
7. Repeat step 5 until all links have been defined.
Specifying the color of text links
There are 3 colors (in addition to the regular text color) which are associated with links on a web page. There is the initial link color (before anyone clicks it on the page), the visited link color (the color the link becomes once it has been clicked and visited), and the active link color (the color the link becomes as you click and hold the mouse on it).

1. From the Modify menu, select Page Properties, select Link under Category. (example below)
2. Click on the color boxes for any of the desired colors, then make your choice and Click OK

Creating a Graphic Link

1. Select the graphic that you want to link.
2. In the Property Inspector, click in the Link text box, type the link you want, and then press Enter.

Previewing Pages Prior to Publishing
It's always a good idea to preview any web page before you publishing it on the web server. This way, you can verify that all the links work and you can fix any formatting problems that appear.

1. From the File menu, select Preview In Browser.
2. On the side menu that appears, you will see a web browser listed, such as Internet Explorer. Just click on the browser you want. The browser will open with your page displaying on the screen.
3. Check all of the links by clicking on them to verify they go to the intended locations. When
everything looks good, you can then publish the finished pages.

4. Close the browser window to return to Dreamweaver.

Publishing Finished Pages
Publishing the finished pages is a snap with Dreamweaver. If you still have the file open:

1. Click the **File Management** button on the toolbar, and then select **Put**. (green and blue arrows)
2. If you've not connected to the web server until now, you are asked to put in your password. Enter your *Alpha* password and press `<Enter>`.
3. Dreamweaver will ask if you want to include dependent files. (These would be files, such as graphics, also included on the page.) *Always click Yes.*

Another way of publishing pages is from the Files panel:

1. Highlight the file(s) you want to publish.
2. Click the **Put** button on the "Files" panel toolbar.
3. Dreamweaver will ask if you want to include dependent files. (These would be files, such as graphics, also included on the page.) Click **Yes**.