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Microsoft Excel 2013: Headers and Footers  

 

You can add headers or footers at the top or bottom of a printed worksheet. For example, you 

might create a footer that has page numbers, along with the date and time. You also might want 

a Header that has a title of your file. These are both done using Headers and Footer. Using the 

Headers and Footers in Excel will keep you sheet with data only which will help when you use 

the data for formulas and merges. 

 

Headers and footers are not displayed on the worksheet in Normal view — they are only 

displayed in Page Layout view and on the printed pages. You can insert headers or footers in 

Page Layout view where you can see them, or you can use the Page Setup dialog box if you 

want to insert headers or footers for more than one worksheet at the same time. For other sheet 

types, such as chart sheets, you can only insert headers and footers by using the Page Setup 

dialog box. 

  

 Add Or Change The Header Or Footer Text In the Page Layout View 

 Add Or Change The Header Or Footer Text In The Page Setup Dialog Box 

 Add A Predefined Header Or Footer 

 Insert Specific Elements In A Header Or Footer 

 Specify Header And Footer Options 

 Close Headers And Footers 

 Remove The Header Or Footer Text From A Worksheet 

Add or Change the Header or Footer Text in the Page Layout View 

 

1. Click the worksheet to which you want to add headers or footers, or that contains headers or 

footers that you want to change. 

2.On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 

 

Excel displays the worksheet in Page Layout view. You can also click Page Layout View   

on the status bar to display this view. 

 Do one of the following: 

 To add a header or footer, click the left, center, or right header or footer text box at the top or 

the bottom of the worksheet page. 

 To change a header or footer, click the header or footer text box at the top or the bottom of the 

worksheet page respectively, and then select the text that you want to change. 

 Type the new header or footer text. 

 To start a new line in a header or footer text box, press Enter. 

 To delete a portion of a header or footer, select the portion that you want to delete in the header 

or footer text box, and then press Delete or Backspace. You can also click the text and then 

press Backspace to delete the preceding characters. 
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 To include a single ampersand (&) in the text of a header or footer, use two ampersands. For 

example, to include "Subcontractors & Services" in a header, type Subcontractors && 

Services. 

 To close the headers or footers, click anywhere in the worksheet. To close the headers or 

footers without keeping the changes that you made, press ESC. 

Add or Change the Header or Footer Text in The Page Setup Dialog Box 

 

1. Click the worksheet or worksheets, chart sheet, or embedded chart to which you want to add 

headers or footers, or that contains headers or footers that you want to change. 

How to select multiple worksheets 

TO SELECT DO THIS 

A single sheet Click the sheet tab.  

 
If you don't see the tab that you want, click the tab scrolling buttons to 

display the tab, and then click the tab. 

 

Two or more 

adjacent sheets 

Click the tab for the first sheet. Then hold down SHIFT while you click 

the tab for the last sheet that you want to select. 

Two or more 

nonadjacent 

sheets 

Click the tab for the first sheet. Then hold down CTRL while you click 

the tabs of the other sheets that you want to select. 

All sheets in a 

workbook 

Right-click a sheet tab, and then click Select All Sheets on the shortcut 

menu. 

 

When multiple worksheets are selected, Group appears in the title bar at the top of the 

worksheet. To cancel a selection of multiple worksheets in a workbook, click any unselected 

worksheet. If no unselected sheet is visible, right-click the tab of a selected sheet, and then click 

Ungroup Sheets on the shortcut menu. 

2.On the Page Layout tab, in the Page Setup group, click the Dialog Box Launcher  next to 

Page Setup. 

 Excel displays the Page Setup dialog box. 

If you selected a chart sheet or embedded chart, clicking Header & Footer in the Text group on 

the Insert tab will also display the Page Setup dialog box. 

3.On the Header/Footer tab, click Custom Header or Custom Footer. 

4.Click in the Left section, Center section, or Right section box, and then click the buttons to 

insert the header or footer information that you want in that section. 

5.To add or change the header or footer text, type additional text or edit the existing text in the 

Left section, Center section, or Right section box. 

 To start a new line in a section box, press ENTER. 
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 To delete a portion of a header or footer, select the portion that you want to delete in the 

section box, and then press DELETE or BACKSPACE. You can also click in the text and then 

press BACKSPACE to delete the preceding characters. 

 To include a single ampersand (&) in the text of a header or footer, use two ampersands. For 

example, to include "Subcontractors & Services" in a header, type Subcontractors && 

Services. 

 To base a custom header or footer on an existing header or footer, click the header or footer in 

the Header or Footer box. 

Add a Predefined Header or Footer 

 

For worksheets, you can work with headers and footers in Page Layout view. For other sheet 

types such as chart sheets, or for embedded charts, you can work with the headers and footers in 

the Page Setup dialog box. 

Add A Predefined Header Or Footer To A Worksheet In Page Layout View 

1. Click the worksheet to which you want to add a predefined header or footer. 

2. On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 

 

Excel displays the worksheet in Page Layout view. You can also click Page Layout View   

on the status bar to display this view. 

3.Click the left, center, or right header or footer text box at the top or the bottom of the 

worksheet page. 

Clicking any text box selects the header or footer and displays the Header and Footer Tools, 

adding the Design tab. 

4.On the Design tab, in the Header & Footer group, click Header or Footer, and then click the 

predefined header or footer that you want. 

 

Add a Predefined Header Or Footer To A Chart 

1. Click the chart sheet or embedded chart to which you want to add a predefined header or 

footer. 

2.  On the Insert tab, in the Header & Footer grouping, click either Header or Footer.  

 Excel displays the Page Setup dialog box. 

3. Click the predefined header or footer in the Header or Footer box. 

Insert Specific Elements in a Header or Footer 

 

For worksheets, you can work with headers and footers in Page Layout view. For other sheet 

types such as chart sheets, or for embedded charts, you can work with headers and footers in the 

Page Setup dialog box. 

 

Insert Specific Header and Footer Elements For A Worksheet  

1.Click the worksheet to which you want to add specific header or footer elements. 

2.On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 
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Excel displays the worksheet in Page Layout view. You can also click Page Layout View   

on the status bar to display this view. 

3.Click the left, center, or right header or footer text box at the top or the bottom of the 

worksheet page. 

Clicking any text box selects the header or footer and displays the Header and Footer Tools, 

adding the Design tab. 

4.On the Design tab, in the Header & Footer Elements group, click the element that you want. 

 

Insert Specific Header and Footer Elements for a Chart  

1. Click the chart sheet or embedded chart to which you want to add a predefined header or 

footer. 

2. On the Insert tab, in the Header & Footer grouping, click either Header or Footer.  

3. Excel displays the Page Setup dialog box. 

4. Click Custom Header or Custom Footer. 

5. Use the buttons in the Header or Footer dialog box to insert specific header and footer 

elements. When you rest the mouse pointer on a button, a ScreenTip displays the name of 

the element that the button inserts. 

Specify Header And Footer Options 

 

For worksheets, you can work with headers and footers in Page Layout view. For other sheet 

types such as chart sheets, or for embedded charts, you can work with headers and footers in 

the Page Setup dialog box. 

Choose The Header And Footer Options For A Worksheet 

1. Click the worksheet for which you want to choose header and footer options. 

2. On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 

3. Excel displays the worksheet in Page Layout view. You can also click Page Layout 

View   on the status bar to display this view. 

4.  Click the left, center, or right header or footer text box at the top or the bottom of the 

worksheet page. Clicking any text box selects the header or footer and displays the 

Header and Footer Tools, adding the Design tab. 

 

On the Design tab, in the Options group, select one or more of the following: 

 Select the Different Odd & Even Pages check box to specify that the headers and footers on 

odd-numbered pages should be different from those on even-numbered pages. 

 Select the Different First Page check box to remove headers and footers from the first printed 

page. 

 Select the Scale with Document check box to specify whether the headers and footers should 

use the same font size and scaling as the worksheet. 

To make the font size and scaling of the headers or footers independent of the worksheet scaling 

to create a consistent display across multiple pages, clear this check box. 

 Select the Align with Page Margins check box to make sure that the header or footer margin 

is aligned with the left and right margins of the worksheet. 
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To set the left and right margins of the headers and footers to a specific value that is independent 

of the left and right margins of the worksheet, clear this check box. 

 

Choose The Header And Footer Options For A Chart 

1. Click the chart sheet or embedded chart to which you want to add a predefined header or 

footer. 

2. On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 

Excel displays the Page Setup dialog box. 

Select one or more of the following: 

 Select the Different Odd & Even Pages check box to specify that the headers and footers on 

odd-numbered pages should be different from those on even-numbered pages. 

 Select the Different First Page check box to remove headers and footers from the first printed 

page. 

 Select the Scale with Document check box to specify whether the headers and footers should 

use the same font size and scaling as the worksheet. 

 To make the font size and scaling of the headers or footers independent of the worksheet scaling 

to create a consistent display across multiple pages, clear this check box. 

 Select the Align with Page Margins check box to make sure that the header or footer margin 

is aligned with the left and right margins of the worksheet. 

 To set the left and right margins of the headers and footers to a specific value that is 

independent of the left and right margins of the worksheet, clear this check box. 

Close Headers and Footers 

 

To close the header and footer, you must switch from Page Layout view to Normal view. 

 On the View tab, in the Workbook Views group, click Normal. 

 You can also click Normal on the status bar. 

Remove The Header Or Footer Text From A Worksheet 

 

1. On the Insert tab, in the Header & Footer grouping, click either Header or Footer. 

2. Excel displays the worksheet in Page Layout view. You can also click Page Layout View  

 on the status bar to display this view. Click the left, center, or right header or footer 

text box at the top or the bottom of the worksheet page. Clicking any text box selects the 

header or footer and displays the Header and Footer Tools, adding the Design tab. 

3. Press Delete or Backspace. 

4. To return to Normal view, click Normal   on the status bar.  

If you want to delete headers and footers for several worksheets at once, select the worksheets 

according to the instructions in Add or change the header or footer text in the Page Setup 

dialog box, and then open the Page Setup dialog box. To delete all headers and footers at 

once, on the Header/Footer tab, select (none) in the Header or Footer box. 

http://office.microsoft.com/client/helppreview.aspx?AssetId=HP100215509990&lcid=1033&NS=EXCEL&Version=12&respos=1&CTT=1&queryid=76db87d67912405289caee9e6a638f25#BMpagesetupheaderfooter
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Custom Page Numbers 

 

The page number by defaults starts at 1, but should you want to change the page number you can 

find this under the Page Layout tab, in the Page Setup icon. Under the First page number, 

change it to suit your needs. 

  

 

  It can also be found on the File tab, Print, Settings, to Page Setup. 

 


